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Introduction 
 
The goal of this guide is to show new Network Workbench (NWB) users the basics of visualizing 
graphs in Network Workbench using the integrated GUESS graph exploration tool. We start by 
describing how to load and process data in Network Workbench for use with GUESS, and go on to 
explain the basic functionality of GUESS, including the basic GUESS interface, the Graph Modifier 
extension to GUESS, and the GUESS Interpreter. 
 
Loading Data into GUESS 
 
To begin using GUESS from Network Workbench (NWB), you must first have a graph that you want 
to visualize. In this guide we will use florentine.nwb, which is a graph available in the 
sampledata/networks directory of your Network Workbench directory. 
 
To load the florentine dataset, select File->Load, open the “sampledata” directory, open the “network” 
directory, and select “florentine.nwb”. 
 
The florentine dataset should now appear in the NWB Data Manager.  
 
To view the contents of this dataset, right-click on the florentine data item in the Data Manager, and 
select “View”. A new window should open containing an nwb file format representation of the 
florentine dataset. Note that each node is annotated with label, wealth, totalties, and priorates 
information, and that each edge is annotated with marriage and business information. Later on, we will 
use these annotations to improve our visualization. 
  
At this point we could go ahead and visualize the graph, but to make it more interesting let's run Node 
Betweenness Centrality on the florentine dataset, to add an additional attribute to the graph's nodes. 
Later on, this will allow us to colorize each node based on how central each node is (for more 
information on Node Betweenness Centrality, see its documentation on the NWB Community Wiki at 
https://nwb.slis.indiana.edu/community/?n=AnalyzeData.BetweennessCentralitySiteAmpEdge ). 
 
To run Node Betweenness Centrality on our graph, select the florentine dataset from the NWB Data 
Manager, and select Analysis -> Unweighted & Undirected -> Node Betweenness Centrality from the 
NWB menu. Accept the default parameters by clicking “OK” in the resulting GUI popup. 
 
Running Node Betweenness Centrality should add several new data items to the Data Manager, 
including a new graph. The newly produced graph is the florentine dataset, except each node is now 
also annotated with a number representing its centrality. To confirm this, select the new graph, right-
click, and select View as before. Note that a value for the new “sitebetweenness” attribute has been 



added to each node. 
 
Now that we have prepared our dataset to our liking, we are ready to run GUESS. Select the most 
recent graph from the Data Manager, and select Visualization -> GUESS from the NWB menu. After a 
few seconds the GUESS window should open. We can now begin familiarizing ourselves with the 
GUESS interface. 
 
Getting to Know GUESS 
 
When GUESS opens, the florentine dataset will be displayed in the main display window. When first 
displayed in GUESS, graphs are laid out randomly, so one of the first steps we usually take is to select 
a new layout for our graph from the GUESS Layout menu at the top of the GUESS window.  
 
Select Layout -> GEM from the GUESS menu. 
 
You should now see a much more orderly layout of the florentine graph in the display window. 
 
You may want to take this opportunity to poke around the GUESS menu a bit. Note that you can 
export images or graphs (under File), you can change the background color of the Display window 
(under Edit), and you can run python scripts (under Script). 
 
Now let's begin exploring some of the GUESS capabilities we have at our disposal. 
 
Hovering your mouse over nodes will display their labels, and hovering your mouse over edges will 
display the labels of the two nodes it connects. Notice that when you hover over a node or edge, its 
information is displayed in the Information Window on the left. 
 
In the Information Widnow, Note that some of the node and edge attributes have been created by 
GUESS (such as the x and y positions), but the rest have been retained from our original graph in 
Network Workbench. Every node still has the same label, wealth, priorates, and totalties attributes, and 
every edge still has the same wealth and marriage attributes. If you ran the Node Betweenness 
Centrality algorithm, nodes should have a sitebetweenness attribute as well. Later we will use this 
information to change how the graph is visualized. 
 
To pan, “grab” the background by holding left-click, and move your mouse to drag the graph. 
 
There are severals ways to zoom in and out in GUESS. You may use your scrollwheel, press the “+” 
and “-” buttons in the upper-left hand corner, or right-click and move the mouse left or right. In 
“Browse” mode, you can also hold shift and left-click/drag to form a box around the area you wish to 
zoom in to. If you zoom too far in and get lost, center the graph by selecting View -> Center from the 
GUESS menu. 
 
“Browse” mode is the default mode in GUESS. GUESS has “Browse”, “Manipulate Nodes”, 
“Manipulate Edges”, “Manipulate Hulls”, and “Draw” modes, which can be selected using the buttons 
on either the left-side of the Display window, or along the bottom of the GUESS Window.  



 
Select the “Manipulate Nodes” mode by clicking on the button on the left side of the Display window 
showing a pointer selecting a yellow node. To move a node, click its center and drag. To change the 
dimensions of a node, select the node and drag the corners of the box which appears around it. To select 
multiple nodes, hold shift and left-click/drag. When multiple nodes are selected, dragging any selected 
node will drag all the selected nodes. 
 
Manipulate Edges mode is less powerful than Manipulate Nodes mode, but can still be used to select 
edges in a similar way. Select a single edge by clicking on it, or select multiple edges by holding shift and 
left-click/dragging over them.  
 
Several options for manipulating nodes and edges are made available by right-clicking on the display 
window while one or more nodes/edges are selected.  
 
Select Manipulate Nodes mode, then select a few nodes, and right-click. This should open a new menu. 
Select “Modify Fields...” from this menu. From the “Select Node Field” drop down box in the resulting 
popup menu, choose “color” if it is not already selected. In the “New Value” field, type “red”, and 
finally hit “Apply”. The nodes you selected should turn red. This technique can be used to change any 
node or edge attribute (Check the GUESS website at http://guess.wikispot.org/Colors for a full list of 
supported colors). 
 
Manipulating Hulls is beyond the scope of this guide. If you would like more information on hulls, see 
the Convex Hull section of the GUESS wiki at http://guess.wikispot.org/Convex_Hulls . 
 
Now click the Draw Mode button. A new panel should appear over the Information Window which 
displays basic drawing functionality. This panel can be used to create shapes or text of various sizes 
and colors.  
 
Let's try drawing some text on our graph. First let's choose the color by clicking on the gray (by 
default) color box at the bottom of the Draw Window buttons. Choose your favorite color and click 
“OK”. Now click on where you would like your text to start on the graph. A new window should 
appear, which lets you edit various characteristics of the text. When you're done, click “OK”. 
 
Be careful with what you draw using Draw Mode, as I am not aware of any way to alter or undo 
anything drawn once it is created (at least, not without hacking around in the Interpreter). Draw 
operations are best performed in the later stages of making a visualization, after everything else has 
been manipulated to your liking. 
  
Using the Graph Modifier 
 
Now that you've become familiar with some of the basic functionality of GUESS, we can move on to 
the Graph Modifier. Graph Modifier is not  a standard component in GUESS, but we include it because 
it exposes some of the more advanced functionality available in the Interpreter in a more approachable 
way. 
 



The Graph Modifier should be visible in a pane at the bottom of the GUESS screen. There are two 
main steps to using the Graph Modifier. First you select which nodes or edges you wish to operate on, 
then you select the operation you wish to perform. 
 
Try selecting “all nodes” in the Object drop-down box, and click the Show Label button. All the labels 
of the nodes should now be visible. 
 
Operating on all nodes or all edges is a fairly basic functionality provided by Graph Modifier, but the 
real value comes from selecting nodes or edges based some attribute.  
 
Now select “nodes based on ->” from the Object drop-down box, then select 
“wealth” from the Property drop-down box, then select “>=” from the Operator drop-down box, and 
finally type “50” into the Value box. Note that for numeric values, you can see the full range of values 
in the graph by clicking the drop-down button on the Value box. For text values the drop down box will 
contain a list of the values currently present in the graph for that attribute. 
 
We have just selected all nodes whose wealth is more than or equal to 50. Now click the Node Shape 
button, and select any shape. The shape of nodes whose wealth is greater than or equal to 50 should 
change. 
 
Finally, try selecting “edges based on ->”, then select “marriage”, then “==”, then choose “T” from the 
drop-down Value box. Now select “Colour”, and choose a new colour for these edges. Now edges 
which represent a “marriage” relationship should have the chosen colour. 
 
Using the Interpreter 
 
The vast majority of GUESS functionality is only available through the Interpeter. The Interpreter is 
extremely powerful, and is one of the major advantages of using GUESS. 
 
 Unfortunately, using the GUESS Interpreter involves writing commands in the Python programming 
language (technically a slightly modifier version called Gython), which can be difficult for users who are 
not fully comfortable with programming. Still, it is possible for non-programming users to make use of 
the Interpreter for certain basic tasks, and after getting over the initial difficulty it should not be too 
hard to write a fair number of useful commands. 
 
More extensive documentation of the interpreter is provided by the official GUESS manual at 
http://guess.wikispot.org/manual , or in the GUESS Intepreter Quick Reference PDF at 
http://www.cs.duke.edu/csed/harambeenet/workshop/sigcse07/GUESSQuickRef.pdf . For now, I will 
mention a few simple commands which are often useful. 
 
The two most common Intepreter commands we typically run are “colorize” and “resizeLinear”. 
 
Bring up the GUESS Interpreter by clicking the “Intepreter” tab near the bottom of the GUESS 
Window. This should cause a command line interface to appear where the Graph Modifier once was. 
(To bring up the Graph Modifier again, simply re-select the Graph Modifier tab near the bottom of the 



GUESS window). 
 
Type “colorize(wealth, white, red)” , without the quotes, into the interpreter, and hit the Enter key. All 
nodes in the graph should now be colored somewhere on the spectrum from white to red, where the 
reddest node is the most wealthy and the whitest node is the least wealthy. 
 
“colorize” takes 3 arguments: an attribute, the start color, and the end color. The attribute can be any 
numeric attribute on nodes or edges (hover over a node or edge and look in the Information Window to 
see a list of available attributes). The start color determines the color of the node with the lowest value 
for the chosen attribute, and the end color determines the color of the node with th highest value for the 
chosen attribute. All other nodes will be somewhere in between, depending on their relative wealth. 
 
“resizeLinear” works similarly to colorize, except it uses the values of an attribute to change a node or 
edges size, instead of changing it's color. Here we can finally use the “sitebetweenness” attribute we 
added to the graph in Network Workbench. “resizeLinear” takes 3 arguments: an attribute, the start 
size, and the end size.  
 
Type “resizeLinear(sitebetweenness, 5, 50)”, without the quotes, and hit the Enter key. All nodes in 
the graph should now be resized according to their sitebetweenness attribute, where the largest node  
has the highest sitebetweenness, and the smallest node has the lowest sitebetweenness. The smallest 
node in this case will be of size 5, and the largest node will be of size 50. 
 
As a small example of the Interpreter's more advanced capabilities,  
try typing the following into the console (and make sure to use the same indentation). 
 
for n in g.nodes: 
 if (n.wealth + n.sitebetweenness) > 100: 
  n.labelvisible = true 
 else: 
  n.labelvisible = false 
 
 
This says that for every node (n) in this graph's (g) nodes, if that node's wealth plus that node's 
sitebetweenness is more than 100, make its label visible. Otherwise make that nodes label not visible. 
 
This isn't a particularly useful example, but it shows how controlling the graph through programming 
can expose powerful functionality which would be difficult to provide through a traditional graphical 
interface. 
 
Here is a more complex example, which over several steps results in turning the top 3 wealthiest nodes 
green. 
 
def bywealth(n1, n2): 
 return cmp(n1.wealth, n2.wealth) 
 



nodes = g.nodes 
nodes.sort(bywealth) 
wealthiestnodes = nodes[-3:] 
 
for n in wealthiest: 
 n.color = green 
 
 
Where To Learn More 
 
The primary documentation for the GUESS standalone tool is available on the GUESS website at 
http://graphexploration.cond.org/documentation.html . The documentation is somewhat spotty, and 
focuses heavily on using the Interpreter, but is overall fairly good. NWB currently uses a more recent 
version of GUESS than what is available as an installable package from the GUESS website, so there 
will be some minor discrepancies in the functionality described in the official GUESS documentation, 
and what is described here. The standard GUESS tool does also does not include the Graph Modifier.  
 
Also, if you're new to programming and wish to better utilize the GUESS Interpreter, try starting with 
“An Informal Introduction to Python” from the official python website at 
http://www.python.org/doc/2.5.2/tut/node5.html 
 
 


